Blog » 2014 » Janeiro » 21 » Próximas versões do Android podem inutilizar aplicativos root

Próximas versões do Android podem inutilizar aplicativos root

As próximas versões do Android podem impedir que programas que necessitem de root funcionem. De acordo com um programador especializado, que se auto intitula Chainfire, o Android deve receber alterações em seus sistemas de arquivos que bloquearão o acesso root em muitos aplicativos.

Segundo ele, o novo código compromete a “árvore mestre” do Android Open Source Project (AOSP) e impede que o superusuário execute arquivos localizados em /data. É bem provável que isso possa ser visto já na próxima versão do SO.

E o que isso significa? Que diversos desenvolvedores terão que atualizar seus aplicativos para driblar a questão. Enquanto não existe uma solução definitiva, Chainfire diz que é importante que a comunidade esteja a par do problema para que possam, juntos, procurar uma forma de superá-lo.

Autor: WWD  |  Data:  |  Visualizações: 476  |  Comentários: 0

Destaques

Comentários
Escreva um comentário
avatar